HDLC driver for MPC860 or 68360

HDLC driver for MPC860 or 68360


[ Follow Ups ] [ Post Followups ] [ FAQ ]
[ Back to Messages ]

Posted by Geetha on June 17, 2000 at 03:15:45:

Hi,
I am looking for some help real soon as I ran into this problem with the HDLC driver for a MPC860 processor. I coded the driver in BSD 4.3 style. The problem I am noticing is as follows:
I can attach the driver to the network layer using if_attach() call and I also initialize the hardware (i.e. SCC2 for HDLC mode). I can see the interface when I do ifShow from the shell. It has everything except the MAC address. However, when I tried to send a ping to the interface I get the mbuf handed to my output routine, but the interface structure send queue is empty. I would appreciate if you folks can let me know if I need to do any other initialization other than if_attach()/ether_attach() and my own hardware initialization. I would be happy to send my code for you folks to take a look. I appreciate your help.
Regards,
Geetha


Follow Ups:


Post a Followup

Please note:
  • Messages must be on the topic of this forum!
  • No posting of requests for cracks, codes, serials, or warez!
  • No posting of illegal software or links to such sites!
  • No use of profanity or inappropriate or offensive language!
  • Spamming is not allowed!
  • We track the IP addresses of forum abusers!
  • Abuse of this forum will be reported to your ISP!
Name:
E-Mail (optional):
please note: your e-mail address will be visible in your message.

Subject:

Comments:

Optional Link URL:
Link Title:
Optional Image URL: