Re: 12 GB (out of 20) of disk space

Re: 12 GB (out of 20) of disk space

[ Follow Ups ] [ Post Followups ] [ FAQ ]
[ Back to Messages ]

Posted by Henry on December 10, 2001 at 11:43:41:

In Reply to: Re: 12 GB (out of 20) of disk space posted by Ole on December 10, 2001 at 08:52:43:

: : : Ola!

: : : I hope someone would care to enlighten me on this problem.

: : : I formated my hard disk using the format c: command in order to reinstall Win98 (did not do any partitioning). Everything worked just fine upon installing WinŽ98, except from the fact that my hard drive now had the capacity 7.something GB. Before the formating it had 19.something.

: : : Whatever happened to the other 12 GB?

: : : Using fdisk i tried to delete all partitions, and re-partition it again, but only the mentioned 7.6 GB are available for this purpose. On starting fdisk I am asked this question on large HDD support (I answer yes), and my BIOS settings have not been changed (not by me, that is).

: : : Hopefully I have just forgotten to perform some operations, and I would be very grateful if someone could tell me what to do /what I should have done.

: : : Thank you very much!

: : : Ole ;o)
: :
: :
: : Your PC's BIOS MUST support "large" HDDs, that is HDDs larger than 8.4GB, typically this would be 32GB or more and you must use FAT32 to use that capacity. A couple of possibilities include a BIOS limit for HDD capacity OR possibly you or someone else initially formatted the drive as a FAT16 volume (you said you formatted without setting up partitons, therefore someone else must have done so else you COULD NOT format your HDD. FAT16 has a limit of 2.1GB per partition; win usually has a limit of 8.4GB in FAT16 partitions.
: :
: : Does your PC recognize the FULL capacity of your HDD (Does Autodetect in CMOS Setup find about 20GB?)? If your BIOS DOES NOT report the full HDD capacity STOP until you can get BIOS support for large HDDs.

: : When you run fdisk and display partition information, does it show FAT16 or FAT32?

: : If you formatted the HDD as FAT16 try to convert to FAT 32 by deleting all partitions with fdisk then build one large partition and format it under Win98 or use your Win98 start-up diskette. If you still have problems you will probably need to erase the drive completely and start over; the procedure I use is:

: : 1. Go to the HDD maker's web site and download the HDD maker's diagnostic utility; that utility should have a "low level format" or erase HDD (or equivalent) function required for HDDs larger than 8.4GB (if not, you may have real trouble). This LLF function does not format anything - it writes zeroes to every user accessible spot on the drive, PERFECTLY SAFE for your HDD - the maker WOULD NOT SUPPLY software that could damage your HDD.

: : 2. Run the maker's diagnostic and run the LLF or erase drive function (or whatever is equivalent). This will give you a drive that is as clean as new, but you should make sure your drive is OK before you use it, YOUR problem if you don't.

: : 3. Run fdisk and partition your HDD (choose YES, You REQUIRE large HDD support) then format it (format cleandrive:/s)- check partition with fdisk - it should display as FAT32.

: : 4. Run scandisk and perform a thorough (Read/Write) surface scan - mainly a precaution - a fairly new HDD should have ZERO bad sectors. In any case, this marks the bad sectors "in use" so they won't be used for your good files.

: : 5. Run the maker's diagnostic and select the most extensive diagnostic choice and run it - overnight if necessary. It appears that sometimes the maker's diagnostic may replace bad sectors found by scandisk with "spare" sectors managed by the drive electronics.

: : At this point you should have a formatted (FAT32) HDD that is qualified for service (or on the way back to the maker if it turned out to be defective) and you should be able to install Win98. Make sure you also install Service Pack 1 and all patches released since then - it can make a BIG difference in operability.

: : Hope this helps,
: : Henry
: :

: Hello again!

: I have tried all solution hints with no success. fdisk displays FAT32 in partition info mode, IDE HDD AUTO DETECT displays 20.something GB capacity, Driver Fitness Test (tool from IBM website) finds no errors (and also recognizes the full capacity and checks for bad cables etc.). The worst is yet to come though; after using DFT to erase disk and master boot records, I again start fdisk, choose support for large HDD, and want to create primary partition - only the mentioned 7.56 GB are available.

: Since both my BIOS and this DFT-tool insists that my HDD has a capacity of 20.something GB (and has no errors), I am likely to assume that I am making a mistake using fdisk, or that my fdisk is not working the way it is supposed to. I do not see where I could be making the mistake though.

: thank you very much!

: ole

Sure sounds like you have an IBM HDD (which model?) and it sounds like an fdisk problem but if you answer YES when fdisk asks if you want large HDD support you SHOULD be OK. Pre-FAT32 editions of fdisk don't recognize FAT32 - they usually call it "non-DOS".

Seems like IBM has Disk Manager posted on their web site - it may partition and format your erased HDD (yes, erase it again) and avoid the need for microsoft fdisk and format.

Good Luck,

Follow Ups:

Post a Followup

Please note:
  • Messages must be on the topic of this forum!
  • No posting of requests for cracks, codes, serials, or warez!
  • No posting of illegal software or links to such sites!
  • No use of profanity or inappropriate or offensive language!
  • Spamming is not allowed!
  • We track the IP addresses of forum abusers!
  • Abuse of this forum will be reported to your ISP!
E-Mail (optional):
please note: your e-mail address will be visible in your message.



Optional Link URL:
Link Title:
Optional Image URL: